duplicati

Come trovare valori duplicati in excel?

Parto dall’ipotesi che l’intervallo di celle con i valori duplicati da controllare sia da A2 ad A60

La formula excel per trovare valori duplicati è la seguente: =CONTA.SE($A$2:$A$60;A2) 

Nella prima parte c’è l’intervallo delle celle su cui cercare e nella seconda la cella contenente il valore da cercare.

Come si usa

Inserisci la formula in una cella a fianco ad ogni riga ma ricordati di usare i Dollari per l’intervallo (vai qui per sapere perché). 

A questo punto, dopo aver trascinato la formula verso il basso, dovresti avere un elenco di 1 o valori maggiori di 1.

Ecco sono proprio quelli maggiori di 1 che rappresentano un valore duplicato.

In fondo a questa pagina trovi due utili Macro VBA Excel

Fammi sapere se ha funzionato con un commento!

Hai problemi da risolvere con Excel?

Clicca il tasto che trovi qui sotto per scrivere la tua richiesta. Puoi allegare anche un file di esempio (max 1 MB).

Sarò lieto di farti una consulenza gratuita o un preventivo per un soluzione costruita solo per te!

2 risposte

  1. in una griglia c3:f8 ci sono alcuni duplicati numerici; se ne possono trovare da 0 a 5; nelle celle G3:G7 se 0 duplicati “”; se un solo duplicato in cella G3 e
    nelle altre “”; se 2 duplicati il primo in cella G3, il secondo in G4 e nelle altre “”; e così per 3 duplicati eccetera. Con formula;
    Se in VBA in base all’area selezionata i risultati in G3:G7. Considerare che le celle mensionate non sono da ritenere assoluto nel senso che il compito non sarà svolto solo per quell’area indicata. Grazie cordialmente una risposta con soluzione.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Iscriviti alla newsletter!